Started by an SCM change Started by an SCM change Running as SYSTEM Building remotely on labmaster2 (Zorg) in workspace /Users/buildslave/jenkins/workspace/LNT_Tests No credentials specified > git rev-parse --is-inside-work-tree # timeout=10 Fetching changes from the remote Git repository > git config remote.origin.url http://labmaster3.local/git/llvm-test-suite.git # timeout=10 Fetching upstream changes from http://labmaster3.local/git/llvm-test-suite.git > git --version # timeout=10 > git fetch --tags --progress http://labmaster3.local/git/llvm-test-suite.git +refs/heads/*:refs/remotes/origin/* # timeout=10 > git rev-parse refs/remotes/origin/master^{commit} # timeout=10 > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10 Checking out Revision 0305e56e7bf5cf4be75b1a557fa72b37fe063572 (refs/remotes/origin/master) > git config core.sparsecheckout # timeout=10 > git checkout -f 0305e56e7bf5cf4be75b1a557fa72b37fe063572 # timeout=10 Commit message: "Revert "Experimental support for spec 2017 on Apple platforms"" > git rev-list --no-walk 0305e56e7bf5cf4be75b1a557fa72b37fe063572 # timeout=10 No credentials specified > git rev-parse --is-inside-work-tree # timeout=10 Fetching changes from the remote Git repository > git config remote.origin.url http://labmaster3.local/git/llvm-lnt.git # timeout=10 Fetching upstream changes from http://labmaster3.local/git/llvm-lnt.git > git --version # timeout=10 > git fetch --tags --progress http://labmaster3.local/git/llvm-lnt.git +refs/heads/*:refs/remotes/origin/* # timeout=10 > git rev-parse refs/remotes/origin/master^{commit} # timeout=10 > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10 Checking out Revision e630ecf2f321b7a37e915a51088983bb109f0d6a (refs/remotes/origin/master) > git config core.sparsecheckout # timeout=10 > git checkout -f e630ecf2f321b7a37e915a51088983bb109f0d6a # timeout=10 Commit message: "Lit is obtained from Git Monoroepo, rather than SVN" > git rev-list --no-walk e630ecf2f321b7a37e915a51088983bb109f0d6a # timeout=10 No credentials specified > git rev-parse --is-inside-work-tree # timeout=10 Fetching changes from the remote Git repository > git config remote.origin.url http://labmaster3.local/git/llvm-project.git # timeout=10 Fetching upstream changes from http://labmaster3.local/git/llvm-project.git > git --version # timeout=10 > git fetch --tags --progress http://labmaster3.local/git/llvm-project.git +refs/heads/*:refs/remotes/origin/* # timeout=10 > git rev-parse refs/remotes/origin/master^{commit} # timeout=10 > git rev-parse refs/remotes/origin/origin/master^{commit} # timeout=10 Checking out Revision b2999264536776aa3c09577290ebf21643bdc492 (refs/remotes/origin/master) > git config core.sparsecheckout # timeout=10 > git checkout -f b2999264536776aa3c09577290ebf21643bdc492 # timeout=10 Commit message: "[IndVars] Fix sort comparator." > git rev-list --no-walk 470db54cbdf1ce65e7084aa42a8c5e9f1c41a9bd # timeout=10 No emails were triggered. [LNT_Tests] $ /bin/sh -xe /var/folders/q0/p3jrdx7n2s74x5bnw_pkhqr80000gn/T/jenkins3873607233784760150.sh + set -u + rm -rf lnt.xunit.xml test-results.xunit.xml + echo '@@@ Configure Build @@@'
Configure Build

Hide Details

@@@ Configure Build @@@ + export PATH=/usr/local/bin/:/usr/bin:/bin:/usr/sbin:/sbin + PATH=/usr/local/bin/:/usr/bin:/bin:/usr/sbin:/sbin + export PYTHON_EGG_CACHE=/Users/buildslave/jenkins/workspace/LNT_Tests/python_egg_cache + PYTHON_EGG_CACHE=/Users/buildslave/jenkins/workspace/LNT_Tests/python_egg_cache + export PIP_DOWNLOAD_CACHE=/Users/buildslave/jenkins/workspace/LNT_Tests/pip_download_cache + PIP_DOWNLOAD_CACHE=/Users/buildslave/jenkins/workspace/LNT_Tests/pip_download_cache + export LANG=en_CA.UTF-8 + LANG=en_CA.UTF-8 + rm -rf venv + virtualenv venv New python executable in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin/python2.7 Also creating executable in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin/python Installing setuptools, pip, wheel...done. + set +u + source venv/bin/activate ++ deactivate nondestructive ++ unset -f pydoc ++ '[' -z '' ']' ++ '[' -z '' ']' ++ '[' -n /bin/sh ']' ++ hash -r ++ '[' -z '' ']' ++ unset VIRTUAL_ENV ++ '[' '!' nondestructive = nondestructive ']' ++ VIRTUAL_ENV=/Users/buildslave/jenkins/workspace/LNT_Tests/venv ++ export VIRTUAL_ENV ++ _OLD_VIRTUAL_PATH=/usr/local/bin/:/usr/bin:/bin:/usr/sbin:/sbin ++ PATH=/Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin:/usr/local/bin/:/usr/bin:/bin:/usr/sbin:/sbin ++ export PATH ++ '[' -z '' ']' ++ '[' -z '' ']' ++ _OLD_VIRTUAL_PS1= ++ '[' x '!=' x ']' +++ basename /Users/buildslave/jenkins/workspace/LNT_Tests/venv ++ PS1='(venv) ' ++ export PS1 ++ alias pydoc ++ '[' -n /bin/sh ']' ++ hash -r + set -u + curl https://bootstrap.pypa.io/get-pip.py + python % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 100 1764k 100 1764k 0 0 3194k 0 --:--:-- --:--:-- --:--:-- 3191k DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support Collecting pip Using cached pip-20.0.2-py2.py3-none-any.whl (1.4 MB) Installing collected packages: pip Attempting uninstall: pip Found existing installation: pip 20.0.2 Uninstalling pip-20.0.2: Successfully uninstalled pip-20.0.2 Successfully installed pip-20.0.2 + echo @@@@@@ @@@@@@
+ echo '@@@ Dependencies @@@'
Dependencies

Hide Details

@@@ Dependencies @@@ + cd /Users/buildslave/jenkins/workspace/LNT_Tests/llvm-lnt + /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin/pip install -r requirements.txt DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support Collecting six Using cached six-1.14.0-py2.py3-none-any.whl (10 kB) Processing /Users/buildslave/Library/Caches/pip/wheels/03/22/40/9b2f558eaa39d530e792583795d55365b67efb4299d0dbd5c7/aniso8601-1.2.0-cp27-none-any.whl Collecting Flask==0.12.2 Using cached Flask-0.12.2-py2.py3-none-any.whl (83 kB) Collecting Flask-RESTful==0.3.4 Using cached Flask_RESTful-0.3.4-py2.py3-none-any.whl (24 kB) Processing /Users/buildslave/Library/Caches/pip/wheels/59/a3/6b/51924066cac6ac011024f40b5575b7a4a0a146836644d8b4cf/Jinja2-2.7.2-cp27-none-any.whl Processing /Users/buildslave/Library/Caches/pip/wheels/28/de/65/f28b426d990edb591113e1549c8a0f09034e5958e440629306/MarkupSafe-0.23-cp27-cp27m-macosx_10_10_x86_64.whl Processing /Users/buildslave/Library/Caches/pip/wheels/c2/05/49/544f56621e6766ebeba43c42f7ea4405bcd37cff04c3e571a6/SQLAlchemy-1.1.11-cp27-cp27m-macosx_10_10_x86_64.whl Collecting Werkzeug==0.12.2 Using cached Werkzeug-0.12.2-py2.py3-none-any.whl (312 kB) Processing /Users/buildslave/Library/Caches/pip/wheels/2c/4a/61/5599631c1554768c6290b08c02c72d7317910374ca602ff1e5/itsdangerous-0.24-cp27-none-any.whl Collecting python-dateutil==2.6.0 Using cached python_dateutil-2.6.0-py2.py3-none-any.whl (194 kB) Processing /Users/buildslave/Library/Caches/pip/wheels/1f/cf/6a/f2821cc41923b0714765ae30fe699d7d7b5d233a208eedd1d6/python_gnupg-0.3.7-cp27-none-any.whl Collecting pytz==2016.10 Using cached pytz-2016.10-py2.py3-none-any.whl (483 kB) Collecting WTForms==2.0.2 Using cached WTForms-2.0.2-py27-none-any.whl (128 kB) Collecting Flask-WTF==0.12 Using cached Flask_WTF-0.12-py2-none-any.whl (12 kB) Collecting typing Using cached typing-3.7.4.1-py2-none-any.whl (26 kB) Collecting click==6.7 Using cached click-6.7-py2.py3-none-any.whl (71 kB) Processing /Users/buildslave/Library/Caches/pip/wheels/ad/da/0c/74eb680767247273e2cf2723482cb9c924fe70af57c334513f/PyYAML-3.13-cp27-cp27m-macosx_10_10_x86_64.whl Collecting requests Using cached requests-2.23.0-py2.py3-none-any.whl (58 kB) Processing /Users/buildslave/Library/Caches/pip/wheels/8b/99/a0/81daf51dcd359a9377b110a8a886b3895921802d2fc1b2397e/future-0.18.2-cp27-none-any.whl Obtaining lit from git+https://github.com/llvm/llvm-project.git#egg=lit&subdirectory=llvm/utils/lit (from -r requirements.client.txt (line 22)) Cloning https://github.com/llvm/llvm-project.git to /Users/buildslave/jenkins/workspace/LNT_Tests/venv/src/lit Running command git clone -q https://github.com/llvm/llvm-project.git /Users/buildslave/jenkins/workspace/LNT_Tests/venv/src/lit Processing /Users/buildslave/Library/Caches/pip/wheels/96/fc/09/f83664f88e8494365b4cb9296d2262ddf189185fb05cd1699a/psycopg2-2.8-cp27-cp27m-macosx_10_10_x86_64.whl Processing /Users/buildslave/Library/Caches/pip/wheels/61/12/6d/27e0d8c49a317c509c131d818b8fc94d1cbfbc61a479d5a396/gunicorn-18.0-cp27-none-any.whl Collecting progressbar2 Using cached progressbar2-3.47.0-py2.py3-none-any.whl (24 kB) Collecting urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 Using cached urllib3-1.25.8-py2.py3-none-any.whl (125 kB) Collecting certifi>=2017.4.17 Using cached certifi-2019.11.28-py2.py3-none-any.whl (156 kB) Collecting chardet<4,>=3.0.2 Using cached chardet-3.0.4-py2.py3-none-any.whl (133 kB) Collecting idna<3,>=2.5 Using cached idna-2.9-py2.py3-none-any.whl (58 kB) Collecting python-utils>=2.3.0 Using cached python_utils-2.3.0-py2.py3-none-any.whl (12 kB) Installing collected packages: six, python-dateutil, aniso8601, itsdangerous, click, MarkupSafe, Jinja2, Werkzeug, Flask, pytz, Flask-RESTful, SQLAlchemy, python-gnupg, WTForms, Flask-WTF, typing, pyyaml, urllib3, certifi, chardet, idna, requests, future, lit, psycopg2, gunicorn, python-utils, progressbar2 Running setup.py develop for lit Successfully installed Flask-0.12.2 Flask-RESTful-0.3.4 Flask-WTF-0.12 Jinja2-2.7.2 MarkupSafe-0.23 SQLAlchemy-1.1.11 WTForms-2.0.2 Werkzeug-0.12.2 aniso8601-1.2.0 certifi-2019.11.28 chardet-3.0.4 click-6.7 future-0.18.2 gunicorn-18.0 idna-2.9 itsdangerous-0.24 lit progressbar2-3.47.0 psycopg2-2.8 python-dateutil-2.6.0 python-gnupg-0.3.7 python-utils-2.3.0 pytz-2016.10 pyyaml-3.13 requests-2.23.0 six-1.14.0 typing-3.7.4.1 urllib3-1.25.8 + /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin/pip install pep8 sphinx sphinx-bootstrap-theme DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support Collecting pep8 Using cached pep8-1.7.1-py2.py3-none-any.whl (41 kB) Collecting sphinx Using cached Sphinx-1.8.5-py2.py3-none-any.whl (3.1 MB) Processing /Users/buildslave/Library/Caches/pip/wheels/71/28/10/e04d1ab1110dbde7f436dd159ed5ee35113f66536df6d99a79/sphinx_bootstrap_theme-0.7.1-cp27-none-any.whl Collecting alabaster<0.8,>=0.7 Using cached alabaster-0.7.12-py2.py3-none-any.whl (14 kB) Requirement already satisfied: Jinja2>=2.3 in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages (from sphinx) (2.7.2) Collecting snowballstemmer>=1.1 Using cached snowballstemmer-2.0.0-py2.py3-none-any.whl (97 kB) Collecting imagesize Using cached imagesize-1.2.0-py2.py3-none-any.whl (4.8 kB) Collecting docutils>=0.11 Using cached docutils-0.16-py2.py3-none-any.whl (548 kB) Requirement already satisfied: six>=1.5 in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages (from sphinx) (1.14.0) Requirement already satisfied: requests>=2.0.0 in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages (from sphinx) (2.23.0) Collecting packaging Using cached packaging-20.1-py2.py3-none-any.whl (36 kB) Requirement already satisfied: typing; python_version < "3.5" in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages (from sphinx) (3.7.4.1) Collecting Pygments>=2.0 Using cached Pygments-2.5.2-py2.py3-none-any.whl (896 kB) Collecting sphinxcontrib-websupport Using cached sphinxcontrib_websupport-1.1.2-py2.py3-none-any.whl (39 kB) Collecting babel!=2.0,>=1.3 Using cached Babel-2.8.0-py2.py3-none-any.whl (8.6 MB) Requirement already satisfied: setuptools in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages (from sphinx) (44.0.0) Requirement already satisfied: markupsafe in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages (from Jinja2>=2.3->sphinx) (0.23) Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages (from requests>=2.0.0->sphinx) (1.25.8) Requirement already satisfied: certifi>=2017.4.17 in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages (from requests>=2.0.0->sphinx) (2019.11.28) Requirement already satisfied: chardet<4,>=3.0.2 in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages (from requests>=2.0.0->sphinx) (3.0.4) Requirement already satisfied: idna<3,>=2.5 in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages (from requests>=2.0.0->sphinx) (2.9) Collecting pyparsing>=2.0.2 Using cached pyparsing-2.4.6-py2.py3-none-any.whl (67 kB) Requirement already satisfied: pytz>=2015.7 in /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages (from babel!=2.0,>=1.3->sphinx) (2016.10) Installing collected packages: pep8, alabaster, snowballstemmer, imagesize, docutils, pyparsing, packaging, Pygments, sphinxcontrib-websupport, babel, sphinx, sphinx-bootstrap-theme Successfully installed Pygments-2.5.2 alabaster-0.7.12 babel-2.8.0 docutils-0.16 imagesize-1.2.0 packaging-20.1 pep8-1.7.1 pyparsing-2.4.6 snowballstemmer-2.0.0 sphinx-1.8.5 sphinx-bootstrap-theme-0.7.1 sphinxcontrib-websupport-1.1.2 + /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin/pip install mysql-python DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support Processing /Users/buildslave/Library/Caches/pip/wheels/07/d2/5f/314860e4cb53a44bf0ee0d051d4b34465e4b4fbe9de6d42f42/MySQL_python-1.2.5-cp27-cp27m-macosx_10_10_x86_64.whl Installing collected packages: mysql-python Successfully installed mysql-python-1.2.5 + killall mysqld No matching processes belonging to you were found + true + /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin/python setup.py develop running develop running egg_info writing requirements to LNT.egg-info/requires.txt writing LNT.egg-info/PKG-INFO writing top-level names to LNT.egg-info/top_level.txt writing dependency_links to LNT.egg-info/dependency_links.txt writing entry points to LNT.egg-info/entry_points.txt reading manifest file 'LNT.egg-info/SOURCES.txt' reading manifest template 'MANIFEST.in' no previously-included directories found matching 'tests/*/Output' writing manifest file 'LNT.egg-info/SOURCES.txt' running build_ext copying build/lib.macosx-10.10-x86_64-2.7/lnt/testing/profile/cPerf.so -> lnt/testing/profile Creating /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages/LNT.egg-link (link to .) Adding LNT 0.4.2.dev0 to easy-install.pth file Installing lnt script to /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin

Hide Details

Installed /Users/buildslave/jenkins/workspace/LNT_Tests/llvm-lnt Processing dependencies for LNT==0.4.2.dev0 Searching for lit==0.11.0.dev0 Best match: lit 0.11.0.dev0 lit 0.11.0.dev0 is already the active version in easy-install.pth Installing lit script to /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/src/lit/llvm/utils/lit Searching for future==0.18.2 Best match: future 0.18.2 Adding future 0.18.2 to easy-install.pth file Installing pasteurize script to /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin Installing futurize script to /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for requests==2.23.0 Best match: requests 2.23.0 Adding requests 2.23.0 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for PyYAML==3.13 Best match: PyYAML 3.13 Adding PyYAML 3.13 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for click==6.7 Best match: click 6.7 Adding click 6.7 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for typing==3.7.4.1 Best match: typing 3.7.4.1 Adding typing 3.7.4.1 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for Flask-WTF==0.12 Best match: Flask-WTF 0.12 Adding Flask-WTF 0.12 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for WTForms==2.0.2 Best match: WTForms 2.0.2 Adding WTForms 2.0.2 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for pytz==2016.10 Best match: pytz 2016.10 Adding pytz 2016.10 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for python-gnupg==0.3.7 Best match: python-gnupg 0.3.7 Adding python-gnupg 0.3.7 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for python-dateutil==2.6.0 Best match: python-dateutil 2.6.0 Adding python-dateutil 2.6.0 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for itsdangerous==0.24 Best match: itsdangerous 0.24 Adding itsdangerous 0.24 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for Werkzeug==0.12.2 Best match: Werkzeug 0.12.2 Adding Werkzeug 0.12.2 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for SQLAlchemy==1.1.11 Best match: SQLAlchemy 1.1.11 Adding SQLAlchemy 1.1.11 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for MarkupSafe==0.23 Best match: MarkupSafe 0.23 Adding MarkupSafe 0.23 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for Jinja2==2.7.2 Best match: Jinja2 2.7.2 Adding Jinja2 2.7.2 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for Flask-RESTful==0.3.4 Best match: Flask-RESTful 0.3.4 Adding Flask-RESTful 0.3.4 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for Flask==0.12.2 Best match: Flask 0.12.2 Adding Flask 0.12.2 to easy-install.pth file Installing flask script to /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for aniso8601==1.2.0 Best match: aniso8601 1.2.0 Adding aniso8601 1.2.0 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for six==1.14.0 Best match: six 1.14.0 Adding six 1.14.0 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for idna==2.9 Best match: idna 2.9 Adding idna 2.9 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for chardet==3.0.4 Best match: chardet 3.0.4 Adding chardet 3.0.4 to easy-install.pth file Installing chardetect script to /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for certifi==2019.11.28 Best match: certifi 2019.11.28 Adding certifi 2019.11.28 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Searching for urllib3==1.25.8 Best match: urllib3 1.25.8 Adding urllib3 1.25.8 to easy-install.pth file

Hide Details

Using /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Finished processing dependencies for LNT==0.4.2.dev0 + cd .. + cd /Users/buildslave/jenkins/workspace/LNT_Tests/llvm-project/llvm/utils/lit + /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin/python setup.py install /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages/setuptools/dist.py:476: UserWarning: Normalizing '0.11.0dev' to '0.11.0.dev0' normalized_version, running install running bdist_egg running egg_info writing lit.egg-info/PKG-INFO writing top-level names to lit.egg-info/top_level.txt writing dependency_links to lit.egg-info/dependency_links.txt writing entry points to lit.egg-info/entry_points.txt reading manifest file 'lit.egg-info/SOURCES.txt' reading manifest template 'MANIFEST.in' warning: no files found matching 'TODO' warning: no previously-included files matching '*pyc' found anywhere in distribution warning: no previously-included files matching '*~' found anywhere in distribution no previously-included directories found matching 'tests/Output' no previously-included directories found matching 'tests/*/Output' no previously-included directories found matching 'tests/*/*/Output' no previously-included directories found matching 'tests/*/*/*/Output' writing manifest file 'lit.egg-info/SOURCES.txt' installing library code to build/bdist.macosx-10.10-x86_64/egg running install_lib running build_py creating build/bdist.macosx-10.10-x86_64/egg creating build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/__init__.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/BooleanExpression.py -> build/bdist.macosx-10.10-x86_64/egg/lit creating build/bdist.macosx-10.10-x86_64/egg/lit/builtin_commands copying build/lib/lit/builtin_commands/__init__.py -> build/bdist.macosx-10.10-x86_64/egg/lit/builtin_commands copying build/lib/lit/builtin_commands/cat.py -> build/bdist.macosx-10.10-x86_64/egg/lit/builtin_commands copying build/lib/lit/builtin_commands/diff.py -> build/bdist.macosx-10.10-x86_64/egg/lit/builtin_commands copying build/lib/lit/cl_arguments.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/discovery.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/display.py -> build/bdist.macosx-10.10-x86_64/egg/lit creating build/bdist.macosx-10.10-x86_64/egg/lit/formats copying build/lib/lit/formats/__init__.py -> build/bdist.macosx-10.10-x86_64/egg/lit/formats copying build/lib/lit/formats/base.py -> build/bdist.macosx-10.10-x86_64/egg/lit/formats copying build/lib/lit/formats/googletest.py -> build/bdist.macosx-10.10-x86_64/egg/lit/formats copying build/lib/lit/formats/shtest.py -> build/bdist.macosx-10.10-x86_64/egg/lit/formats copying build/lib/lit/LitConfig.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/LitTestCase.py -> build/bdist.macosx-10.10-x86_64/egg/lit creating build/bdist.macosx-10.10-x86_64/egg/lit/llvm copying build/lib/lit/llvm/__init__.py -> build/bdist.macosx-10.10-x86_64/egg/lit/llvm copying build/lib/lit/llvm/config.py -> build/bdist.macosx-10.10-x86_64/egg/lit/llvm copying build/lib/lit/llvm/subst.py -> build/bdist.macosx-10.10-x86_64/egg/lit/llvm copying build/lib/lit/main.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/ProgressBar.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/run.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/ShCommands.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/ShUtil.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/Test.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/TestingConfig.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/TestRunner.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/util.py -> build/bdist.macosx-10.10-x86_64/egg/lit copying build/lib/lit/worker.py -> build/bdist.macosx-10.10-x86_64/egg/lit byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/__init__.py to __init__.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/BooleanExpression.py to BooleanExpression.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/builtin_commands/__init__.py to __init__.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/builtin_commands/cat.py to cat.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/builtin_commands/diff.py to diff.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/cl_arguments.py to cl_arguments.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/discovery.py to discovery.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/display.py to display.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/formats/__init__.py to __init__.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/formats/base.py to base.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/formats/googletest.py to googletest.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/formats/shtest.py to shtest.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/LitConfig.py to LitConfig.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/LitTestCase.py to LitTestCase.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/llvm/__init__.py to __init__.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/llvm/config.py to config.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/llvm/subst.py to subst.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/main.py to main.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/ProgressBar.py to ProgressBar.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/run.py to run.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/ShCommands.py to ShCommands.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/ShUtil.py to ShUtil.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/Test.py to Test.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/TestingConfig.py to TestingConfig.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/TestRunner.py to TestRunner.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/util.py to util.pyc byte-compiling build/bdist.macosx-10.10-x86_64/egg/lit/worker.py to worker.pyc creating build/bdist.macosx-10.10-x86_64/egg/EGG-INFO copying lit.egg-info/PKG-INFO -> build/bdist.macosx-10.10-x86_64/egg/EGG-INFO copying lit.egg-info/SOURCES.txt -> build/bdist.macosx-10.10-x86_64/egg/EGG-INFO copying lit.egg-info/dependency_links.txt -> build/bdist.macosx-10.10-x86_64/egg/EGG-INFO copying lit.egg-info/entry_points.txt -> build/bdist.macosx-10.10-x86_64/egg/EGG-INFO copying lit.egg-info/not-zip-safe -> build/bdist.macosx-10.10-x86_64/egg/EGG-INFO copying lit.egg-info/top_level.txt -> build/bdist.macosx-10.10-x86_64/egg/EGG-INFO creating 'dist/lit-0.11.0.dev0-py2.7.egg' and adding 'build/bdist.macosx-10.10-x86_64/egg' to it removing 'build/bdist.macosx-10.10-x86_64/egg' (and everything under it) Processing lit-0.11.0.dev0-py2.7.egg creating /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages/lit-0.11.0.dev0-py2.7.egg Extracting lit-0.11.0.dev0-py2.7.egg to /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages Removing lit 0.11.0.dev0 from easy-install.pth file Adding lit 0.11.0.dev0 to easy-install.pth file Installing lit script to /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin

Hide Details

Installed /Users/buildslave/jenkins/workspace/LNT_Tests/venv/lib/python2.7/site-packages/lit-0.11.0.dev0-py2.7.egg Processing dependencies for lit==0.11.0.dev0 Finished processing dependencies for lit==0.11.0.dev0 + cd .. + cd /Users/buildslave/jenkins/workspace/LNT_Tests/llvm-lnt/tests/ + echo @@@@@@ @@@@@@ + echo '@@@ Test LNT @@@'
Test LNT

Hide Details

@@@ Test LNT @@@ + rm -rf test_run_tmp + /Users/buildslave/jenkins/workspace/LNT_Tests/venv/bin/lit -j1 --xunit-xml-output=/Users/buildslave/jenkins/workspace/LNT_Tests/lnt.xunit.xml -v --param postgres=True --param mysql=True . -- Testing: 72 tests, 1 workers -- PASS: LNT :: Formats/json.py (1 of 72) PASS: LNT :: Formats/plist.py (2 of 72)