FailedChanges

Changes from Git (git http://labmaster3.local/git/llvm-project.git)

Summary

  1. [OPENMP][DOCS]Update status of OpenMP 5.0 features, NFC. (details)
  2. [X86] Add STRICT versions of CVTTP2SI, CVTTP2UI, CMPM, and CMPP. (details)
  3. test: ensure that we dead-strip in the linker (details)
  4. [mlir] Fix -Wunneeded-internal-declaration (details)
  5. [X86] Use 128-bit vector instructions for f32/f64->i64 conversions on (details)
  6. [compiler-rt] Adapt stop-the-world for ptrace changes in NetBSD-9.99.30 (details)
  7. [compiler-rt] Adapt for ptrace(2) changes in NetBSD-9.99.30 (details)
  8. [lldb] Adapt for NetBSD-9.99.30 ptrace(2) API changes (details)
Commit 3cb934c94e518486a8cd066ff02d176ec040e87b by a.bataev
[OPENMP][DOCS]Update status of OpenMP 5.0 features, NFC.
The file was modifiedclang/docs/OpenMPSupport.rst
Commit a21beccea2020f950845cbb68db663d0737e174c by craig.topper
[X86] Add STRICT versions of CVTTP2SI, CVTTP2UI, CMPM, and CMPP.
Differential Revision: https://reviews.llvm.org/D71850
The file was modifiedllvm/test/CodeGen/X86/avx512dqvl-intrinsics.ll
The file was modifiedllvm/lib/Target/X86/X86InstrFragmentsSIMD.td
The file was modifiedllvm/lib/Target/X86/X86InstrSSE.td
The file was modifiedllvm/test/CodeGen/X86/avx512vl-intrinsics-upgrade.ll
The file was modifiedllvm/lib/Target/X86/X86ISelLowering.h
The file was modifiedllvm/test/CodeGen/X86/avx512vl-intrinsics.ll
The file was modifiedllvm/lib/Target/X86/X86InstrAVX512.td
The file was modifiedllvm/lib/Target/X86/X86ISelDAGToDAG.cpp
The file was modifiedllvm/test/CodeGen/X86/avx512-intrinsics.ll
The file was modifiedllvm/test/CodeGen/X86/avx512dq-intrinsics.ll
The file was modifiedllvm/lib/Target/X86/X86ISelLowering.cpp
The file was modifiedllvm/test/CodeGen/X86/avx512vl-intrinsics-fast-isel.ll
Commit 64c6bb37832c2139a91801fece96de8898151079 by Saleem Abdulrasool
test: ensure that we dead-strip in the linker
`/OPT:REF` is needed for link to dead strip functions, `/Gy` by itself
is not sufficient.
The file was modifiedlldb/packages/Python/lldbsuite/test/functionalities/dead-strip/Makefile
Commit 020ca0cf2f1470db24fe0e194467a66fdea73795 by maskray
[mlir] Fix -Wunneeded-internal-declaration
The file was modifiedmlir/test/mlir-cpu-runner/include/mlir_runner_utils.h
Commit c06e53119b1f04696fbcf710aaa0818cbfc99600 by craig.topper
[X86] Use 128-bit vector instructions for f32/f64->i64 conversions on
32-bit targets with avx512dq and avx512vl instructions.
On 32-bit targets we can't use the scalar instruction so we insert the
scalar into a vector and use packed conversions. Previously we used
either v4f32->v4i64 or v4f64->v4i64 to avoid some complexity creating
target specific ISD opcodes for v4f32->v2i64. But this causes extra
vzeroupper instructions and possibly frequency throttling on Intel CPUs.
This patch changes this to create a 128-bit vector and uses a target
specific ISD opcode if needed.
The file was modifiedllvm/lib/Target/X86/X86ISelLowering.cpp
The file was modifiedllvm/test/CodeGen/X86/scalar-fp-to-i64.ll
Commit fc356dcc11c10003ff22acff667b0a9f5e6c1e0f by n54
[compiler-rt] Adapt stop-the-world for ptrace changes in NetBSD-9.99.30
Handle PT_LWPNEXT for newer kernels and keep PT_LWPINFO for older ones.
The file was modifiedcompiler-rt/lib/sanitizer_common/sanitizer_stoptheworld_netbsd_libcdep.cpp
Commit 4b8232d4f0bf5fd9f11ebef2b0f9e8e15f130fb3 by n54
[compiler-rt] Adapt for ptrace(2) changes in NetBSD-9.99.30
Enable compat support for now legacy PT_LWPINFO. Support PT_LWPSTATUS
and PT_LWPNEXT.
The file was modifiedcompiler-rt/lib/sanitizer_common/sanitizer_syscalls_netbsd.inc
The file was modifiedcompiler-rt/lib/sanitizer_common/sanitizer_platform_limits_netbsd.h
The file was modifiedcompiler-rt/lib/sanitizer_common/sanitizer_platform_limits_netbsd.cpp
The file was modifiedcompiler-rt/include/sanitizer/netbsd_syscall_hooks.h
The file was modifiedcompiler-rt/utils/generate_netbsd_syscalls.awk
Commit ab8a7a29bf15c6eb1d4393516cde1688dbe7dc45 by n54
[lldb] Adapt for NetBSD-9.99.30 ptrace(2) API changes
Switch from PT_LWPINFO to PT_LWPSTATUS/PT_LWPNEXT.
Keep compat support for < 9.99.30.
No functional change intended.
The file was modifiedlldb/source/Plugins/Process/NetBSD/NativeThreadNetBSD.cpp
The file was modifiedlldb/source/Plugins/Process/NetBSD/NativeProcessNetBSD.cpp